is.Watermark (Водяной знак) [1.5.X]

Please log in or регистрация to like posts.
Модули

is.Watermark (Водяной знак) [1.5.X]

Знак настраивается на кэшированные изображения, т.е. если настроить модуль и потом сбросить кэш изображений, то все изображения будут с водяными знаками.
Оригинальные изображения модуль не затрагивает!

Функциональная спецификация:

  • Возможность использования в виде водяного знака заранее подготовленного изображения.
  • Возможность использования в виде водяного знака произвольного текста (цвет, размер, гарнитура).
  • Использование своей гарнитуры при генерации текстового водного знака.
  • Настройка прозрачности водяного знака.
  • Настройка наклона водяного знака.
  • Настройка положения водяного знака относительно изображения (+ смещение).
  • Задание папок, на которые накладывается водяной знак.
  • Задание минимально допустимого размера изображения для накладывания знака.
  • Масштабирование водяного знака в зависимости от размера изображения.

Установка:

  • Скопировать модуль в админку.
  • Заменить файл: /catalog/model/tool/image.php
  • Добавить файлы шрифтов TTF в директорию /system/fonts/
  • Сделать настройку модуля в админке.
[button size=»small» color=»green» style=»none» new_window=»true» link=»http://oc.infosolutions.ru/admin/»]Админка (demo; demo)[/su_button]           [button size=»small» color=»red» style=»none» new_window=»false» link=»http://www.feofan.net/wp-content/uploads/2014/03/watermark.zip»]Скачать[/su_button]

Мнение

0
0
0
0
0
0
Уже отреагировал на этот пост.

14 comments on “is.Watermark (Водяной знак) [1.5.X]

  1. OcStore 1551 получаю ошибку
    Fatal error: Call to undefined method ModelToolImage::onesize() in /home/xxxxxx.ua/www/vqmod/vqcache/vq2-catalog_controller_product_category.php on line 256
    Как исправить?

  2. Все работает отлично. Спасибо. Но как настроить , чтобы водяной знак не выводился на рекламных банерах и на главном слайд шоу. Подскажите что сделать? как настроить?

  3. как ни старалась на 1.5.5.1.2 так и не заработал модуль…. в чем ошибка даже не понятно…

    • попробуйте использовать только текст. у меня на 1.5.5.1.2 текст работает исправно а вот фото нет

  4. На demo админки есть вкладка «Добавить знак»
    Как реализованно подобное ?

  5. у меня тоже это модуль не заработал.. как не старался…

  6. все отлично заработало, надо просто было все выставить правильно в админке

  7. Все таки картинку «стырять» можно путь с сайта к примеру: http://домен/image/cache/500-500/data/demo/samsung_tab_1.jpg
    то удаляя часть: cache/500-500/ получается (физическое место положение картинки: http://silver-trend.com.ua/image/data/demo/samsung_tab_1.jpg — она без надписи. Интерес в том «выкупают» ли это поисковики и все же картинка у Вас получается «вне безопасности», жаль!

  8. Или лучше узнать как индексирует поисковик картинку ту что со знаком или ту, что без знака.
    Со знаком это «динамическая» или «генерирована» картинка, вопрос в этом.

  9. Я не понимаю почему у меня на изображениях выходит зеленое квадратное лицо?

  10. Скачала и установила, с настройками легко разобралась. ОС 1.5.6.4. Но возникла проблема, т.к. модуль переписал image.php, перестали открываться поп-ап превью фото в категориях, почему-то изменился путь, по которому пыталось загрузиться фото. Пришлось удалить модуль, к сожалению.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *